VCF Operations plugin does not load in vCenter after CP certificate change, fails with error "Download plug-in"
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VCF Operations plugin does not load in vCenter after CP certificate change, fails with error "Download plug-in"

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Article ID: 433379

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Updated On:

Products

VCF Operations

Issue/Introduction

  • When the certificate on cloud proxy is replaced, the VCF Operations plugin in vCenter stops working.

Environment

VCF Operations 9.0.x

Cause

The persistent certificate reversion is caused by a synchronization mismatch between the Managed Object Browser (MOB) and the local certificate file /storage/vcops/user/conf/ssl/south_cert.pem. During reconciliation cycles, the system prioritizes the stale local file, overriding applied changes. Updating south_cert.pem resolves the desynchronization.

Resolution

  1. Connect to vCenter appliance using ssh.
  2. Retrieve Cloud Proxy certificate by running the below command from vCenter appliance 
    • # openssl s_client -connect <Cloud_Proxy_Address>:443 | openssl x509
  3. Connect to Cloud Proxy appliance using ssh
  4. Take a backup of the file south_cert.pem by running below command
    • # cp /storage/vcops/user/conf/ssl/south_cert.pem /storage/vcops/user/conf/ssl/south_cert.pem.bak
  5. Edit the file south_cert.pem using vi editor and paste the certificate content from step 1
  6. After 5 minutes the plugin should be automatically updated and error should be gone.