Database created or deleted from VCFA may stuck in InProgress or Deleting status
search cancel

Database created or deleted from VCFA may stuck in InProgress or Deleting status

book

Article ID: 433364

calendar_today

Updated On:

Products

VMware Data Services Manager for VCF

Issue/Introduction

  • Databases management capability may not work as expected from VCFA and tasks may stuck in InProgress or Deleting status on VCFA interface.

  • Upgrading VKS to version 3.5.0 or VKS 3.6.0 will cause Data Services Manager versions 9.0.0 and 9.0.1 to become inoperable.

  • VKS 3.5.0 with DSM 9.0.1  causes rolling updates on existing DatabaseClusters and new DatabaseCluster creations fail.

  • From the DSM the database creation and deletion work as expected.

Environment

  • VMware Data Services Manager 9.0.1

  • VCFA 9.0.1

  • VKS 3.5 and 3.6

Cause

  • The issue would occur due to the VKS API changes in version 3.5. 

  • Due to the API changes in the VKS 3.5.0 and VKS 3.6.0, they are not compatible with Data Services Manager 9.0.0 and 9.0.1. 

Reference: 

VMware Data Services Manager 9.0.1 Release Notes

VMware vSphere Kubernetes Service Release Notes 

Resolution

  • If the VKS version is already 3.5, please upgrade the DSM and VCFA to 9.0.2 which fixes the compatibility.

  • Fixing the components compatibility would address the API to work as expected would allow the database management capability.

Additional Information

VCFA provisioned databases auto spin out or crash during VKS upgrade.

Unable to provision new DBs on VMware Data Services Manager(DSM) 9.0.1, after upgrading vSphere Kubernetes Service(VKS)from 3.4.1 to 3.5.