Post reboot of the ESXi host, the host's network will be down
search cancel

Post reboot of the ESXi host, the host's network will be down

book

Article ID: 433363

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • After rebooting an ESXi host, the management IP (vmk0) becomes unreachable via ICMP (ping) and shows not responding on the VCenter.
  • The host may briefly respond to pings during the early boot sequence but loses connectivity once the management service fully initializes.
  • Restarting the management network via the DCUI restores connectivity. Refer: Restart the Management Agents
  • Verify the management interface mapping after the reboot by running esxtop-->pressing n to identify the specific physical adapter (vmnicX) bound to vmk0. Once identified, its observed that the connectivity gets restored if the management traffic is failed over to the second NIC. So, the traffic is interrupted through a specific NIC alone.
    • Note: To enforce the traffic to the second NIC, the primary NIC needs to be brought down
      esxcli network nic down -n vmnicX

Environment

VMware ESXi

Cause

The issue is caused by a communication failure on a specific physical uplink. When the ESXi host reboots, the teaming policy when active-active may select the faulty NIC as the active path for the vmk0 interface.

Resolution

Workaround:

For standard switches:

Host > Configure > Networking > Virtual Switches

  • Navigate to the portgroup on which the Management vmkernel resides on.
  • Click on the 3 dots beside the portgroup and click on edit settings

  • Click on Teaming and Failover tab
  • Move the faulty NIC, down to unused state

  • Ensure the functional NIC is set to Active.
  • Reboot the host to verify that management connectivity persists using the working active uplink.

Permanent Fix:

Reach out to your physical network team to check why traffic is not passing through the faulty vmnicX.

The following steps can be followed:

  • Confirm that the physical switch port for the faulty vmnicX has the correct VLAN trunking
  • Verify if the MAC address of vmk0 is being learned on the specific physical switch port associated with the faulty vmnicX  .
  • Swap the physical cables between the working vmnic and non working vmnic.

Additional Information

Other Reference articles: After rebooting or updating ESXi, the host loses network connection