Host warning vmsyslog logger ###.###.###.###:514 lost # log messages repeatedly occurred due to a lot of "NFC VERBOSE" logging
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Host warning vmsyslog logger ###.###.###.###:514 lost # log messages repeatedly occurred due to a lot of "NFC VERBOSE" logging

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Article ID: 433262

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Host repeatedly reports vmsyslog logger ###.###.###.###:514 lost # log messages.

You might see a lot of NFC VERBOSE logging like these.

YYYY-MM-DDThh:mm:ss.###Z info hostd[######] [Originator@6876 sub=Libs opID=#####] [NFC VERBOSE]NfcAioServerProcessMain: Processing an operation
YYYY-MM-DDThh:mm:ss.###Z info hostd[######] [Originator@6876 sub=Libs opID=#####] [NFC VERBOSE]NfcAioServerProcessMain: Exiting
YYYY-MM-DDThh:mm:ss.###Z info hostd[######] [Originator@6876 sub=Libs opID=#####] [NFC VERBOSE]NfcAioServerProcessMain: Scheduling a HandleRead
YYYY-MM-DDThh:mm:ss.###Z info hostd[######] [Originator@6876 sub=Libs opID=#####] [NFC VERBOSE]NfcAioServerProcessMain: Exiting processing loop

Environment

VMware vSphere ESXi

Cause

The log spew happens because of NFC verbose logging. The log level can be usually configured by VDDK client, which is typically backup software.

You might see log like this, which indicates log level was set to VERBOSE.

YYYY-MM-DDThh:mm:ss.###Z info hostd[######] [Originator@6876 sub=Libs opID=#####] Setting NFC log level to 4

 

Resolution

The NFC log flood was caused by VDDK client requesting debug log, which is usually a backup software.

Identify the client who creates NFC session and engage an appropriate vendor to minimize NFC log level.

vmauthd.log might be helpful for identifying IP address of NFC session creator.

YYYY-MM-DDThh:mm:ss.###Z vmauthd[##########]: Connect from <IP Address>
YYYY-MM-DDThh:mm:ss.###Z vmauthd[##########]: Received PROXY command for vpxa-nfc, session = ########-####-####-####-############