ERROR with inserting NULL into table "IMSAUDITTASKSESSION12" column "ADMIN_DN"
search cancel

ERROR with inserting NULL into table "IMSAUDITTASKSESSION12" column "ADMIN_DN"

book

Article ID: 433246

calendar_today

Updated On:

Products

CA Identity Suite CA Identity Manager

Issue/Introduction

Customer noticed following error in their server.log:

ERROR [ims.audit] (default task-XXX) Auditing failed with exception [ ORA-01400: cannot insert NULL into ("<audit DB name>"."IMSAUDITTASKSESSION12"."ADMIN_DN")
ORA-06512: at "<audit DB name>.INSERTIMSAUDITTASKSESSION125", line 31
ORA-01403: no data found
ORA-06512: at "<audit DB name>.INSERTIMSAUDITTASKSESSION125", line 20
ORA-06512: at line 1
 ]

Environment

Identity Manager 14.X or 15.X

Cause

Imsaudittasksession12 and Imsauditevent12 tables in audit database of IM are created by default with option set to prevent  inserting null values into column admin_dn.

 

Resolution

If auditing is enabled for Identity Manager some audited tasks might be created without admin_dn information.

We suggest to search for the action causing such situation and changing it so it will provide value for admin_dn.

Additional Information

As a workaround customer with help of their database admin team may change column admin_dn in tables Imsaudittasksession12 and Imsauditevent12 to allow null values.

Make sure to provide correct table name as you run the query.

MS SQL Server:

ALTER TABLE [<Table name>] ALTER COLUMN [admin_dn] [nvarchar] (512) NULL

 

Oracle

ALTER TABLE <Table name> MODIFY ADMIN_DN VARCHAR2 (512) NULL;