vSAN Health Service will not start and does not display any of the vSAN health/monitoring or administration insider of the vCenter GUI
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vSAN Health Service will not start and does not display any of the vSAN health/monitoring or administration insider of the vCenter GUI

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Article ID: 433194

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

When attempting to restart all services from the VCSA CLI or reboot, the vmware-vsan-health service fails to start.

The following vSAN log entry is contained in /var/log/vmware/vsan-health/vmware-vsan-health.log :

YYYY-MM-DDTHH:MM:SS INFO vsan-mgmt[######] [VsanMgmtServer::GetPidFile opID=noOpId] The pid file is /var/log/vmware/vsan-health/vmware-vsan-health.pid
YYYY-MM-DDTHH:MM:SS CRITICAL vsan-mgmt[######] [VsanMgmtServer::UncaughtExcpetionHandler opID=noOpId] Traceback (most recent call last):
   File "bora/vsan/health/vpxd/VsanMgmtServer.py", line 292, in <module>
   File "bora/vsan/health/vpxd/VsanMgmtServer.py", line 119, in Daemonize
 PermissionError: [Errno 13] Permission denied: '/var/log/vmware/vsan-health/vmware-vsan-health.pid'

Environment

VMware vCenter 8.x

Cause

There is a stale vmware-vsan-health.pid file with a previous PID contained within the file that is no longer valid.

Resolution

Stop any running instance of vsanvcmgmtd:

# vmon-cli -k vsan-health 

Backup the vmware-vsan-health.pid file:

# cp /var/log/vmware/vsan-health/vmware-vsan-health.pid /var/log/vmware/vsan-health/vmware-vsan-health.pid.bkp

Remove the existing vmware-vsan-health.pid file:

# rm /var/log/vmware/vsan-health/vmware-vsan-health.pid

Restart the vsanvcmgmtd service and monitor for it to start:

# vmon-cli -r vsan-health

Log out of the vCenter GUI and login again to check if the service started and is showing inside the GUI.

Note:  Depending on the size of the environment and other variables, it may take several minutes before the information shows/is populated within vCenter.