Custom log forwarding port settings not persisting in UI
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Custom log forwarding port settings not persisting in UI

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Article ID: 433169

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Updated On:

Products

VCF Operations VMware Cloud Foundation

Issue/Introduction

  • Custom syslog port values reverting to 514

Environment

  • Aria for Logs, Log Insight, vRLI: 9.0.0.0
  • VCF: 9, 9.0, 9.0.1, 9.0.2

Cause

  • Known issue with the UI. 
  • Issue is cosmetic and does not impact log forwarding.

Resolution

  • This issue is known and is benign.
  • The custom syslog port is honored while the UI displays the incorrect syslog port value.

Confirm log forwarding success/configuration

  • Review the /storage/core/loginsight/var/stats.log file to confirm log forwarding success:

Example:
forward-success-message-rate-<IP>-<port>:
count = 778793278
mean rate = 111.72 rate/s
1-minute rate = 60.14 rate/s
5-minute rate = 58.58 rate/s
15-minute rate = 60.16 rate/s

  • Query the API for log forwarding configuration:
  1. Download the attached logForwarderConfigs.py script.
  2. Copy/SCP the script to the master node.
  3. SSH into the master node as root user.
  4. Run the logForwarderConfigs.py script to obtain the IP and Ports associated to all saved Log Forwarders:

    python3 logForwarderConfigs.py -H <master FQDN> -U admin -P <password>


    Note: Replace <masterFQDN> and <password> with the appropriate values.

    Example output:

    NAME                      | HOST                   | PORT
    -----------------------------------------------------------------
    TestSyslog                | 11.22.33.44            | 11808
    TestSyslog02              | 1.2.3.4                | 11514

  5. Ensure the API is returning the customlog forwarding port value

 

Attachments

logForwarderConfigs.py get_app