Orchestrator Workflows failing with 401 - "Unauthorized" errors when calling Automation API
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Orchestrator Workflows failing with 401 - "Unauthorized" errors when calling Automation API

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Article ID: 433130

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Updated On:

Products

VCF Automation

Issue/Introduction

After an Automation outage, Orchestrator Workflows which call Automation APIs may start failing with 401 - "Unauthorized" errors.

Environment

VCF Automation 9.0.x

Cause

Orchestrator may have lost it's API permissions/authorization from Automation.

Resolution

  1. In the Automation tenant, log in as the tenant admin.
  2. Click the username in the top-right of the UI and select "My Account". 
  3. Under "API tokens", select 'New' to create a new token for Orchestrator to use. 
  4. In Orchestrator UI, run workflow "Update a VCF Automation Host" and added the new API token as an input.

Additional Information

Logging for this type of issue will be improved in future versions of Orchestrator.