ACMQ_Init: error = 44569 in UNAB agent_debug
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ACMQ_Init: error = 44569 in UNAB agent_debug

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Article ID: 433129

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Updated On:

Products

CA Privileged Access Manager - Server Control (PAMSC)

Issue/Introduction

Installing UNAB, the whole process completes correctly and registration and activation are successful

However, the UNAB endpoint is not visible in the Enterprise Management (ENTM) console or Utility appliance (UTA) that it is reporting to

In the <UNAB_HOME>/log/debug/agent_debug file there are the following entries on starting UNAB

20260311060358.727 T139833108754240 L 5: Checking connectivity to <UTA_or_ENTM>:61616 ...
20260311060358.729 T139833108754240 L 3: Scheduler: Reading ActiveMQ message queue
20260311060358.729 T139833108754240 L 3: Currently, there are no policy rules for UNAB.
20260311060358.729 T139833108754240 L 3: Scheduler: Policy verification completed successfully
20260311060358.729 T139833108754240 L 3: Scheduler: Preparing heartbeat command
20260311060358.840 T139833108754240 L 1: ACMQ_Init: error = 44569 (Failed to read communication parameters.)
20260311060358.840 T139833108754240 L 1: Scheduler: TQueue Init failed, rc=44569
20260311060358.840 T139833108754240 L 1: SThread: Scheduled task 'SendHeartBeat' failed with rc=44569
20260311060447.779 T139833104748352 L 3: HealthCheck: Checking agent critical parameters
20260311060457.904 T139833108754240 L 3: Scheduler: registered with CA PAMSC
20260311060507.915 T139833108754240 L 3: Scheduler: Cleaning LDAP connections
20260311060517.926 T139833108754240 L 3: Scheduler: Refreshing DC list in connection pool
20260311060517.926 T139833108754240 L 3: Locating '_ldap._tcp.Default-First-Site-Name._sites.dc._msdcs.<domain_name>.' resource records in the DNS
20260311060517.932 T139833108754240 L 3: Connection pool '<domain_name>' DCs: <DC_server_name>
20260311060547.844 T139833104748352 L 3: HealthCheck: Checking agent critical parameters

Cause

This is caused by a missing password file in <Installation_dir>/PAMSCShared/data which contains the data for communicating with ActiveMQ in the ENTM or Utility Appliance

File is:

-r--------   1 root root    34 Mar 13 09:22 .acmqclient.dat

This is an expected situation of the Communication Password has not been established in UNAB, which will happen under these circumstances

  • Only UNAB is running in that endpoint. UNAB installation does not prompt for the Communication Password at installation or startup time
  • PAM SC has been installed but not the ReportAgent component. At PAM SC installation time, when ReportAgent is installed, the user is prompted for the Communication Password and the corresponding file is being created. But if no ReportAgent is installed, this never happens and the file is not created

Resolution

There ar several possibilities here

  • Copy the file from another working UNAB installation. Make sure the permissions and ownership are the ones specified for the original file and also that the file is not modified during the process to prevent tampering
  • Use utility acuxchkey under <UNAB_HOME>/bin to set the communications password. For instance

<UNAB_HOME>/bin/acuxchkey -t -pw <password_here>

As per the documentation the default Communication Password is N0tall0wed