Root account of Aria Operations Cloud Proxy disconnected in SDDC Manager
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Root account of Aria Operations Cloud Proxy disconnected in SDDC Manager

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Article ID: 433117

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

  • The root account of an Aria Operations Cloud Proxy node displays a "disconnected" status within SDDC Manager.
  • FQDN of the disconnected root account shows as localhost

Note:

Resource Type for Aria operations nodes in password management section of SDDC Manager may show blank. To validate if the affected account belongs to Aria operations, place the pointer in the Resource type column of the affected account and it will show as VROPS for Aria operations nodes

To further validate if the affected account belongs to which Aria operations node(Primary, Replica, Data, cloudproxy):

    • login to Aria Suite LifecycleLifecycle Operations > Environments
    • Select the environment containing Aria Operations
    • Under product, select each section and identify which Aria operations node has localhost set as FQDN.
  • Direct SSH login to the Cloud Proxy node using the root credentials succeeds, but password remediation operations triggered from SDDC Manager fail.
  • In the /var/log/vmware/vcf/operationsmanager/operationsmanager.log on SDDC Manager, you will see below error during remediation attempt

ERROR [vcf_om,,74ec] [c.v.e.s.c.u.c.SshCommandExecuter,om-exec-27] Could not connect to the SSH server @ localhost for configuration.
com.jcraft.jsch.JSchException: java.net.ConnectException: Connection refused

Environment

  • VMware SDDC Manager 5.2 
  • VMware Aria Operations 8.18

Cause

The Fully Qualified Domain Name (FQDN) of the Cloud Proxy node is incorrectly configured as localhost and synced to SDDC Manager. During password remediation, SDDC Manager attempts to establish an SSH session to localhost instead of the actual Cloud Proxy network address, resulting in a connection failure.

Resolution

1. Modify the Aria Operations Cloud Proxy hostname from localhost to its correct network FQDN by referring to How to change a node hostname in Aria Operations

2. Synchronize Inventory from Aria Suite Lifecycle

  • Log in to Aria Suite Lifecycle.
  • Navigate to Lifecycle Operations > Environments.
  • Select the environment containing Aria Operations.
  • click the horizontal ellipses on the product card and click Trigger Inventory Sync

3. Verify that the updated Cloud Proxy hostname is correctly reflected in both Aria Suite Lifecycle and SDDC Manager.

4. Retry the credential update operation from the SDDC Manager UI.

Additional Information

Inventory synchronization in VMware Aria Suite Lifecycle