'Service or view is not available for the selected object' error for SDDC Manager in VCF Operations
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'Service or view is not available for the selected object' error for SDDC Manager in VCF Operations

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Article ID: 433093

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Updated On:

Products

VCF Operations

Issue/Introduction

  • When navigating to Administration and clicking on the SDDC Manager in VMware Cloud Foundation (VCF) Operations, the following error is displayed in the UI:

    Service or view is not available for the selected object
    Details: Try again later in a couple of minutes
    Next steps: Should the issue continue, please check adapter Collection Status

  • The duplicate adapter was removed from the VCF Operations integration, but it is automatically re-created once every 24 hours following deletion

  • The /storage/log/vcops/log/analytics.audit-<UUID>.log log file shows errors similar below:

    INFO audit ######## [ops@#### threadId="####" userId="#######-####-####-####-##########" username="lcm-ops" authSource="LOCAL" session="#######-####-####-####-##########" clientIP="##.###.##.##" auditID="ADAPTER_INSTANCE_CREATE"] [AuditLog.log] - Creating adapter instance succeeded. ID: "#######-####-####-####-##########", Name: "<Adapter-Name>"

  • Additionally, the /storage/log/vcops/log/web-vcf.log log file shows errors similar to the following:

    WARN  web-vcf ##### [ops@#### threadId="#####" threadName="plugin-discovery"] [com.vmware.vcf.operations.ui.vcenter.extensibility.ExtensibilityProvider.warning] - VCFDetail list is empty. Skipping refresh!
    ERROR web-vcf ##### [ops@#### threadId="#####" threadName="plugin-discovery"] [com.vmware.vcf.operations.ui.data.DataProvider.error] - A JSONArray text must start with '[' at 1 [character 2 line 1]
    org.json.JSONException: A JSONArray text must start with '[' at 1 [character 2 line 1]
            at org.json.JSONTokener.syntaxError(JSONTokener.java:503) ~[json-##########.jar:?]
    WARN  web-vcf ##### [ops@#### threadId="#####" threadName="plugin-discovery"] [com.vmware.vcf.operations.ui.vcenter.extensibility.PluginDiscovererImpl.warning] - Empty vCenter extensibility infos received from backend

 

Environment

VMware Cloud Foundation (VCF) Operations 9.x

Cause

The VCF account is added as an adapter twice (once utilizing the FQDN and once utilizing the IP address). This duplicate configuration causes a conflict that prevents the view from rendering.

Resolution

Please Open a case with Broadcom Support to resolve this issue by referencing this KB article in your case. For detailed instructions, see Creating and Managing Broadcom Support Cases.