Import of existing VCF Operations Fleet Management fails and can't be retried
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Import of existing VCF Operations Fleet Management fails and can't be retried

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Article ID: 433037

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Errors in VCF Installer appliance logs may contain errors like VCF_OPS_MGMT_IMPORT_FAILED, FAILED_TO_POLL_VCF_OPS_MGMT_DEPLOYMENT_STATUS and in SDDC Manager/domainmanager logs a "Connection timed out" pointing to the existing Fleet Management appliance.

Environment

VCF 9.0.x

Cause

At the time of the initial import operation the Fleet Management appliance was N/A.

Resolution

As a workaround, please follow the below steps:

  1. Ensure that Fleet Management appliance VM is in healthy state and can be connected from SDDC Manager appliance.
  2. Find the failing task execution id from SDDC Manager/domainmanager.log (might differ depending on the date of the first execution) - should be found as a value of _executionId around the following text:
    "Contract task PrepareVcfOperationsManagementImport input: {"_executionId":"****************"
  3. Via curl executed from SDDC Manager appliance verify that the above execution can be queried
    curl localhost/domainmanager/workflows/${replace_with_executionId} -X GET
  4. Via curl in the same session run a PATCH request that should retrigger the execution
    curl localhost/domainmanager/workflows/${replace_with_executionId} -X PATCH
    Note: The status of the execution can be monitored via the same GET in the previous point

  5. When the execution is finished successfully retry the VCF Installer workflow from Installer UI/API.