Error CAUAJM_E_10010 is produced when running the job_depends
search cancel

Error CAUAJM_E_10010 is produced when running the job_depends

book

Article ID: 433031

calendar_today

Updated On:

Products

Autosys Workload Automation

Issue/Introduction

There are reports of error CAUAJM_E_10010 when running the job_depends command with the -e (extended) option for a large number of jobs (approx. 20K). The process would consume up to 12.5GB of memory and eventually terminate without releasing the space.

The as_server process page space climbed significantly, leading to a "Client is not reachable" error and API termination.

Environment

WAAE 24.1

Cause

The job_depends utility was unable to allocate enough memory to handle the high volume of data being transmitted from the Application Server to the console. The predefined cache size was being exceeded during the forecast generation.

Resolution

Increase the message queue size to allow for higher application output by exporting an environment variable MB4Q=64 before running job_depends

Longer term solution is to add MB4Q=64 to the $AUTOSYS/autosys.sh.[HOSTNAME] file to ensure the setting persists and prevents future recurrence.