Error 'Unable to complete Sysinfo operation. Please see the VMkernel log file for more details.: Not found : VSI node (105:VSI_net_tcpip_instances_plumb)' when enabling the VMkernel adapters
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Error 'Unable to complete Sysinfo operation. Please see the VMkernel log file for more details.: Not found : VSI node (105:VSI_net_tcpip_instances_plumb)' when enabling the VMkernel adapters

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Article ID: 432951

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  1. vSAN Skyline Health reports alerts for vSAN: Basic (unicast) connectivity check and  vSAN: MTU check (ping with large packet size)
  2. The vSAN VMkernel adapter may appear missing or misconfigured in the vSphere Client. 
  3. When attempting to enable a VMkernel (vmk) adapter for vSAN networking, the operation fails with the following error:
    Unable to complete Sysinfo operation. Please see the VMkernel log file for more details.: Not found : VSI node (105:VSI_net_tcpip_instances_plumb)

                

Environment

VMware  vSphere ESXi 
VMware vSphere vCenter

Cause

Inconsistency in the TCP/IP stack configuration

Resolution

To resolve this inconsistency in the TCP/IP stack, recreate the vSAN VMkernel adapter:
  1. Check the Host UI/vSphere Client to see if the VMK adapter is visible.
  2. Login to the ESXi host via SSH and remove the impacted vSAN VMK adapter using the following command (take note of the IP configuration):
      # esxcli network ip interface remove -i vmkx
      (Replace vmkx with the specific ID)
  3. Re-add the VMkernel adapter using the same IP configuration and services (e.g., vSAN) via the vSphere Client.

Additional Information

Create a VMkernel Adapter on a vSphere Distributed Switch