Symantec Management Agent Upgrade Failed: Failed to parse aexnscupgrade.xml The system cannot locate the object specified
search cancel

Symantec Management Agent Upgrade Failed: Failed to parse aexnscupgrade.xml The system cannot locate the object specified

book

Article ID: 432808

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

After upgrading to 8.8, Symantec Management Agent upgrades on endpoints failed. 

The agent logs showed these two entries:

  1. Command line: AeXNSAgentInst.exe /s /installxml="C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{47E1F709-5EF8-44EA-9A1A-955620A09ED4}\cache\aexnscupgrade.xml"
  2. Failed to parse 'C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{47E1F709-5EF8-44EA-9A1A-955620A09ED4}\cache\aexnscupgrade.xml', no organizational group will be assigned, error: The system cannot locate the object specified (0x800C0006)

When reviewing the install logs located at "C:\ProgramData\Symantec\Symantec Agent\InstallLogs\AEXNSC.log", we see 

  1. INFO InstallPrecheck: Command line: AeXNSAgentInst.exe /s /installxml="C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{47E1F709-5EF8-44EA-9A1A-955620A09ED4}\cache\aexnscupgrade.xml"
  2. *ERRR Installer: Failed to parse 'C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{47E1F709-5EF8-44EA-9A1A-955620A09ED4}\cache\aexnscupgrade.xml', no organizational group will be assigned, error: The system cannot locate the object specified (0x800C0006)

Verified that the file, aexnscupgrade.xml, was not present in the folder listed.

In reviewing the agent installation package on the Notification Server, we found that the file was missing there too. In a default installation, this file would be here:

C:\Program Files\Altiris\Notification Server\NSCap\bin\Win32\X86\NS Client Package

Cause

Unknown, but at some point this file was deleted. This file is created or recreated at the end of an upgrade of the platform using the Symantec Installation Manager (SIM).

Resolution

Contact technical support to obtain instructions on how to rebuild aexnscupgrade.xml.

As a work-around, we placed a copy of aexnscupgrade.xml from another 8.8 environment into the NS Client Package folder (in a default installation path, this would be C:\Program Files\Altiris\Notification Server\NSCap\bin\Win32\X86\NS Client Package) and was then able to successfully upgrade the Symantec Management Agent on managed endpoints. 

 

Additional Information

Tech Support - see internal notes for steps to resolve.