Tasks processed partially or completely but not shown in Identity Manager View Submitted Tasks
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Tasks processed partially or completely but not shown in Identity Manager View Submitted Tasks

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Article ID: 432781

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Updated On:

Products

CA Identity Suite

Issue/Introduction

We are having an issue of not seeing many tasks in IM VST even though those were received through WS and IM responded with transaction ID to the APIGW. The task seem not to process completely well, PX in charge of writing the last password date change into user attribute works and leaves the date and time in the user, but we see no trace of this or the main task in the IM.

In IM logs we are seeing also:

(ActiveMQ-client-global-threads)) swapEncryptedDataIn :: Couldn't read Password Bolb data of the usernull

Environment

Release : 14.5.1
Component : Identity Manager

Cause

The API Gateway configuration still referenced both:

IM 14.5 (new environment)

IM 14.4 (old decommissioned environment)

As a result, the gateway routed requests to both environments depending on the routing logic (load balancing or endpoint configuration).

 

In Identity Manager, tasks are recorded in the VST database of the instance that processes the request.

If a request is sent to a different environment:

The task will only exist in that environment's database.

It will not appear in the VST of another instance.

Resolution

Updated the API Gateway configuration to route requests only to the IM 14.5 environment.