Day 2 operations stuck in progress with "Maximum request length exceeded" errors in wapi logs
search cancel

Day 2 operations stuck in progress with "Maximum request length exceeded" errors in wapi logs

book

Article ID: 432755

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Day 2 operations for certain machines are stuck in progress with no tasks reaching vCenter.
  • The Elmah logs under Program Files (x86)/VMware/vCAC/Web API/Logs/Elmah/error-Date&Timestamp contain a "Maximum request length exceeded" error similar to:


    type="System.Web.HttpException" message="Maximum request length exceeded." source="System.Web" detail="System.AggregateException: One or more errors occurred.

Environment

vRealize Automation 7.x

Cause

The request length exceeds the default limits set in the Iaas web stack.

Resolution

 

To resolve the issue increase the Maximum request length.


1) On each IaaS web server backup the file Program Files (x86)/VMware/vCAC/Web API/web.config

2) Change line in file Program Files (x86)/VMware/vCAC/Web API/web.config file 


from:

<httpRuntime targetFramework="4.5" />

to:

<httpRuntime targetFramework="4.5" maxRequestLength="15360" maxQueryStringLength="146384" />


3) Perform IISRESET in command prompt for changes to take effect.   (To avoid any service interuptions during IISRESET you can first disable iaas web node in the loadbalancer )

Additional Information

The same issue can also cause properties to not load in the UI , for example machines with a large number of custom properties. In this instance you make the changes outlined above to the file Program Files (x86)\VMware\vCAC\Server\Website\web.config