Error "Failed to login" in VC Collection Status when using system managed credentials
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Error "Failed to login" in VC Collection Status when using system managed credentials

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Article ID: 432694

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Updated On:

Products

VCF Operations

Issue/Introduction

  • When navigating In VCF Operations for Logs to Integrations > vSphere, the VC Collection Status is Error
  • Hovering the cursor over the Error icon shows "Failed to login"
  • The integration is configured to use a system managed credential (identified by a username that is svc-li-vc-<guid>-#@vsphere.local)

Environment

  • VCF Operations 9.0.x
  • VCF Operations for Logs 9.0.x

Cause

The system managed credential has failed to rotate or the VCF Operations for Logs appliance was reverted to a snapshot or restored from a backup that was created before the credential was rotated.

Resolution

  1. Log in to VCF Operations and navigate to Administration > Integrations

  2. Expand the VCF adapter, then expand the VCF Instance, then expand the domain, then click Edit next to the vCenter adapter.

  3. Click Rotate next to System Managed Credential

  4. Verify that a dialog that says "Info: Successfully rotated System managed credential" is seen and click OK, then click Save.

    Note: It can take up to 10 minutes for the credential in VCF Operations for Logs to be updated.

  5. Log in to the VCF Operations for Logs UI and navigate to Integrations > vSphere. Verify that the VC Collection Status for the vCenter changes to Collecting

    Note: The status may change from Error to Unknown before changing to Collecting. It may take up to 5 minutes before the status changes to Collecting.

 

Tip: To verify the system managed credential was updated, review the configuration of the vSphere integration and verify that the # at the end of the configured username was incremented.

Example: svc-li-vc-<guid>-2@vsphere.local will become svc-li-vc-<guid>-3@vsphere.local when successfully rotated