VCF Operations for Logs cannot be integrated with VCF Identity Broker
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VCF Operations for Logs cannot be integrated with VCF Identity Broker

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Article ID: 432693

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Updated On:

Products

VCF Operations

Issue/Introduction

  • Attempting to configure VCF Ops for Logs to use a cluster-based identity source from VCF Identity Broker unsuccessfully.
  • The VCF SSO configuration page is prompting for the Host, API port, tenant, username and password which are not correct fields.

Environment

  • VCF Operations 9.0.x
  • VCF Operations for Logs 9.0.x
  • VCF Identity Broker 9.0.x

Cause

The license for VCF Operations for Logs is not applying correctly causing the UI to show the wrong configuration page for VCF SSO.

Note: If you log in to the VCF Operations for Logs UI in an incognito window, you will see a banner that says  "Your evaluation has expired and your service has been degraded."

Resolution

  1. Log in to VCF Operations and navigate to Administration > Integrations

  2. Review the vCenter Adapter configurations and verify that at least one of the vCenters is configured to send logs directly to the Logs cluster

  3. Log in to VCF Operations for Logs and navigate to Integrations > vSphere

  4. Validate that the status of at least one of the licensed version 9 vCenters that are configured to send logs directly to the Logs cluster is in Collecting state

  5. After the license is correctly applied, navigate in VCF Operations for Logs to Configration > Authentication > VCF SSO and validate that the configuration is prompting for the expected fields  (Identity Provider Name, VCF Identity Broker Issuer, Client ID, and Client Secret) and complete the VCF SSO configuration