Configuring Site Recovery Manager to connect to vCenter using an alternative SSO Account
search cancel

Configuring Site Recovery Manager to connect to vCenter using an alternative SSO Account

book

Article ID: 432635

calendar_today

Updated On:

Products

VMware vCenter Server VMware Site Recovery Manager 8.x VMware Site Recovery Manager VMware Live Recovery

Issue/Introduction

VMware Site Recovery Manager (SRM) requires configuration to connect to the associated vCenter Server utilizing an alternative Single Sign-On (SSO) user account. The registration process fails if the targeted account lacks the mandatory administrative privileges.

Environment

VMware Site Recovery Manager (SRM) 8.x, 9.x
VMware vCenter Server 7.x, 8.x

Cause

The alternative SSO user account specified for the SRM appliance connection lacks the requisite administrative privileges within the vCenter Single Sign-On domain to successfully register and authenticate the service.

Resolution

1. Log in to the vSphere Client utilizing an existing vCenter Single Sign-On administrator account (e.g., [email protected]).
2. Navigate to Administration > Single Sign-On > Users and Groups
3. Select the Groups tab and click on the Administrators group.
4. Add the intended alternative user account to the vCenter Single Sign-On Administrators group.
5. Log in to the Site Recovery Manager Appliance Management Interface.
6. Configure the SRM appliance to connect to the vCenter Server using the newly privileged alternative user account.

Additional Information

For comprehensive requirements and configuration steps, refer to the official documentation:
https://techdocs.broadcom.com/us/en/vmware-cis/live-recovery/site-recovery-manager/8-8/site-recovery-manager-installation-and-configuration-8-8/site-recovery-manager-appliance-overview/configure-the-site-recovery-manager-appliance-to-connect-to-a-vcenter-server.html