eHealth stops polling when changing system timezone
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eHealth stops polling when changing system timezone

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Article ID: 43263

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Updated On:

Products

CA eHealth

Issue/Introduction

Issue: 

After changing the Time zone on the server, eHealth stops polling

Environment:  

eHealth all versions

Cause: 

When changing the Time zone, the time on the server changes as well. This affects the date/time stamp of each poll recorded by eHealth after making the change. If changing the Time Zone moves the system back, then eHealth will be affixing date/time stamps for new polls that are earlier than its last recorded poll. This will prevent eHealth from writing the data to the DB since it cannot write any record with an earlier date/time stamp than its last record.

Resolution:

Simply allow the system date/time to catch up to the last eHealth record date/time. This would be date/time prior to the change in Time zone. Once the date/time stamps of each poll are later than the last record in the DB, eHealth will write these polls to the DB.

Additional Information:

tec1273793

 

Environment

Release: LHDEVC99000-6.3-eHealth-Live Health Upgrade Elements
Component: