CA Patch management Patches won't download. The patch end up in Status :Packaging Failed
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CA Patch management Patches won't download. The patch end up in Status :Packaging Failed

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Article ID: 43262

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Patch Manager

Issue/Introduction

When I accept patches, they will not download. 


Example:

Patch Google Chrome 50.0.2661.102 x86 {12b4551b-ac14-45ce-b7b8-e04e53615936}  status changed from STATUS_PACKAGING to STATUS_PACKAGING FAILED  

Environment

CA Client Automation - All Versions

Patch Manager - All Version   

Cause

Check the logs for error messages 

For Version 14.x 

   ....... \CA\DSM\PatchManagement\pmEngine.log ,  

 For 12.X version ; 

   .........\CA\SC\UPM\upm.log 

 

 If the logs shows below messages , try the resolutions below. 

connect(): failed

2016-05-13 09:00:03,790 [DownloadedPatchTask] FATAL [com.ca.pmengine.eventmanager] - Error connecting to DSM Server.

Reason: SME_SEC_NEED_CREDS The client must provide explicit credentials to complete authentication as unified logon is not available.

Patch CA - Win 7 Post SP1 32Bit x86 OS Only - FULL Security Rollup v1605.00 {1a712461-7d39-4c1a-a8a8-e9efe9fc1236} package registration failed

Patch Google Chrome 50.0.2661.102 x86 {12b4551b-ac14-45ce-b7b8-e04e53615936} package registration failed
Unexpected exception caught processing Downloaded Patch CA - Win 2012 Post Gold 64Bit x64 OS Only - FULL Security Rollup v1503.00 
{83e931c8-b752-4390-bfee-a3490523f7fe}

Resolution

1.   In Patch manager Under Administration -> Manager  This is the UserName and Password that connect UPM to DSM EXplorer

  a. Check the User Name and Password are Correct. 

  b. Verify that User ID has rights to connect to DSM and create SD Packages.

  c.  Make sure the Password is correct, or Change  the user ID you used to login to OS and  WAC console 

 


  

2. Add the UserID in ITCM\Security profile and Assign  Full Class Permissions 

 

3. From command prompt , run the following:

CAF STOP TOMCAT 

IISRESET

CAF START TOMCAT

 

4.  Change Patch status back to Pending user Acceptance by using SQL Queries:

For All Versions prior to R14: 

use mdb

UPDATE ca_install_package SET status=3 WHERE status = 8

 

- Status 3 is for Pending User Acceptance

- Status 8 is for Packaging Failed

For Version R14:

Just Accept the Patch