404 Error Retrieving AZ/Network Configuration
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404 Error Retrieving AZ/Network Configuration

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Article ID: 432482

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Updated On:

Products

VMware Tanzu Platform - Hub

Issue/Introduction

During an inventory collection or automated retrieval of tile entities from Ops Manager, the collector fails when attempting to fetch Availability Zone (AZ) and Network information.

The process errors out entirely rather than skipping the missing data, leading to incomplete inventory logs. The specific error observed is:

time=2026-03-07T06:28:15.06113596Z caller=logger.go:85 level=error message="failed to get OpsManager NetworksAndAzs for product" GUID=p-fim-4475a8bfcf679ed044f1 InstallationName=p-fim-4475a8bfcf679ed044f1 error="[OpsManager] Unexpected response status code 404 Not Found"
time=2026-03-07T06:28:15.061324027Z caller=logger.go:85 level=error message="inventory error for type Tanzu.TAS.Tile" error="[OpsManager] Unexpected response status code 404 Not Found"

Environment

Tanzu Hub 10.3.3

Cause

Some tiles are non-managed or add-ons that inject agents into existing VMs rather than deploy its own. Therefore, it does not have an assigned Network or AZ in the Opsman UI.

Resolution

This will be fixed in a future release of Tanzu Hub.