NSX installation fails with an error "Failed to install software on host. There is a version mismatch between the ESX host and the vLCM cluster desired state."
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NSX installation fails with an error "Failed to install software on host. There is a version mismatch between the ESX host and the vLCM cluster desired state."

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Article ID: 432462

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

  • During VCF 9 deployment, NSX installation fails to complete. Navigate to Host cluster in NSX Manager, NSX UI > Fabric > Hosts > Clusters tab shows all hosts in a cluster with NSX Configuration as 'Install Failed'.

 

  • Click on View Details, shows "Failed to install software on host. There is a version mismatch between the ESX host and the vLCM cluster desired state. Please remediate this issue from the vCenter."

Environment

VCF 9.x

Cause

The error is encountered when there is a version mismatch between the ESX host and the vLCM cluster desired state.

Resolution

The remediation should be performed from vCenter server. The cluster image needs to be changed to match the version of ESX host.

  • Follow the steps mentioned in Edit an Image in Image Library to make changes.
  • There might be a need to update Vendor Addon as well, if applicable.
  • Once the image is updated, apply to a Cluster.
  • Return to NSX Manager UI and click on 'Refresh icon' underneath Node Status.
  • 'Apply NSX Solution' task shall be initiated. You can see the status for the entire cluster in vCenter Task Manager.

Additional Information

Further observations: No action required under the following scenario

  • NSX Solution shall be applied across multiple ESX hosts.
  • The status for each host shall be at 22%.
  • For the host that NSX solution is being applied, the status shall progress further.
  • Upon completion for one ESX host, you shall see other host status in NSX Manager as 'Install Failed' which is normal.
  • This operation shall be reattempted by SDDC Manager automatically.
  • The behavior repeats upon each successful installation of NSX Solution for each ESX host.
  • If no progress is made for 5-10 minutes, navigate to SDDC manager and click on retry for the failed operation.