Issue in login to CA PM Portal after upgrade of portal, DR and DA to 24.3.13
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Issue in login to CA PM Portal after upgrade of portal, DR and DA to 24.3.13

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Article ID: 432460

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

We are unable to login into CA PM Portal after upgrade of portal, DR and DA using local or/and sso users.

Upgraded from 23.3.9 to 24.3.13

After the upgrade was completed, users were unable to login to the portal using local (admin) account, or ldap accounts.
We see only a generic error in the SingleSignOnAuditLog<DATE>.log



2026-03-07 07:25:35, Product Code: pc, Username: <LDAP-USER>, Remember Me: false, SSO version: 7.0, Remote Host: <IP>, Redirect URL: https://<PORTAL-HOST>:8182/pc/desktop/page?GroupID=1&GroupPathIDs=1, Error Message: Unable to authenticate user.
2026-03-07 07:38:12, Product Code: pc, Username: <LOCAL-USER>, Remember Me: false, SSO version: 7.0, Remote Host: <IP>, Redirect URL: https://<PORTAL-HOST>:8182/pc/desktop/page?GroupID=1&GroupPathIDs=1, Error Message: Unable to authenticate user.


But if we use the SsoConfig script to test ldap, we do see an error message referencing failure to contact KDC.TEST.COM

   (KDC.TEST.COM is a generic address used in the default configuration file, and is not a real URL, but is the exact error you will see)

 

Environment

DX NetOps 24.3.13

Ldap and kerberos enabled

Cause

This was caused by the upgrade moving the file:
/opt/CA/PerformanceCenter/sso/webapps/sso/configuration/krb5.conf
To 
/opt/CA/PerformanceCenter/sso.backup/webapps/sso/configuration/krb5.conf


And replacing the original with the non-configured default file.

Resolution

Move the krb5.conf from sso.backup to sso and restart services.