Telegraf agent installation on Windows Platform fails with "Failed to download"
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Telegraf agent installation on Windows Platform fails with "Failed to download"

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Article ID: 432309

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Installation of a telegraf agent in a windows server failing

Environment

Aria Operations 8.18.x

VCF Operations 9.x

Cause

from uag_boostrap.log we see the following:

C:\Users\userxxx\AppData\Local\Temp\VMware-UCP_Bootstrap_Scriptsvmware14>if 1 NEQ 0 (
if NOT "!errDict_1!" == "" (set msg=!errDict_1! )  
 call :logMesg ERROR "Failed to download:  https://CP-FQDN/IP:443/downloads/salt/config-utils.bat. errcode=1, errmsg=!msg!"  
 set retCode=1  
 if "1" == "1" (
call :setExitStatus "1" "FAILED" "Failed to download:  https://CP-FQDN/IP:443/downloads/salt/config-utils.bat. errcode=1, errmsg=!msg!"  
 goto :_EOF 
) 
) 

Resolution

The issue is resolved by pointing the download address to the cloud proxy IP. Make sure:

1. ssh to the cloud proxy, and check the network configuration, make sure the IP is not set to DHCP server. 

2. Update the download address to point to the cloud proxy FQDN or IP and not DHCP server IP/FQDN