Intermittent error with VMware Identity Manager (vIDM) 404 continues after opensearch index rebuild
book
Article ID: 432062
calendar_today
Updated On:
Products
VCF Operations/Automation (formerly VMware Aria Suite)
Issue/Introduction
- Unable to login to the vIDM intermittently with AD
- The error below appears when the login fails
"The page you were looking is not available. You may need to contact your administrator with this error. 404 Page Not Found."
Environment
VMware Identity Manager 3.3.7
Cause
The temp folder contains the wrong permission.
- Command:
ls -lrth /db
- Result:
drwxr-xr-x 2 root root 4.0K Feb x xx:xx temp
Resolution
- SSH to vIDM nodes with root
- Check the temp folder permission by running:
- Command:
ls -lrth /db
- Result:
drwxr-xr-x 2 root root 4.0K Feb x xx:xx temp
- Run command to change the permission:
- Command:
chwon -R horizon:www /db/temp
- Result:
drwxr-xr-x 2 horizon www 4.0K Feb x xx:xx temp
- Restart the horizon service on the modified nodes:
service horizon-workspace restart
Feedback
thumb_up
Yes
thumb_down
No