vSphere HA virtual machine failover failed because the maximum VM restart count was reached
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vSphere HA virtual machine failover failed because the maximum VM restart count was reached

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Article ID: 432033

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Environment

VMware vCenter Server

Cause

This is the expected behavior when a protected VM cannot be successfully powered on or registered on any HA enabled host in the cluster. Once the maximum restart attempts are exhausted, HA stops its attempts to prevent an infinite loop of failure.

Resolution

To clear the alarm and restore functionality, follow the workaround below:

  1. Locate the affected host in the vSphere Client.
  2. Right-click the host and select Reconfigure for vSphere HA.

The workaround above restarts the FDM (Fault Domain Manager) agent on the specific host and clears the stuck alarm state

 

Additional Information

It is important to Identify why the VM failed to restart and ensure the root cause preventing the VM restart is resolved; otherwise, the alarm will recur during the next failover event. More information in

vSphere HA Fails to Restart Some VMs During Host Outages