VCF instance page not properly displayed in VCF Operations
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VCF instance page not properly displayed in VCF Operations

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Article ID: 432028

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Updated On:

Products

VCF Operations

Issue/Introduction

  • When navigating to Fleet Management -->Lifecycle-->select the VCF instance under “VCF Instances”, the page fails to be displayed with below error. The lifecycle of VCF instance cannot be managed from VCF Operations due to this:

    Domain not configured
    Please configure the domain to use this capability.

  • The VMware Cloud Foundation account is added to VCF Operations but it appears that the data and metrics from the VCF instance are not getting collected by VCF Operations. 
  • After triggering an inventory sync, another VMware Cloud Foundation account is found added to VCF Operations integrations.
  • The VCF Operations and fleet management are not created by VCF installer, instead the two appliances are created manually and later merged to VCF 9.0 environment with VCF installer.

Environment

VMware Cloud Foundation Operations 9.x

Cause

There're VCF instance entries left in the fleet management appliance database which are not deleted automatically after deleting VCF instance integration in VCF Operations. The entries will get synced to VCF Operations during inventory sync and will cause issue with new VCF instance integration. 

Resolution

Issue can be fixed with following steps:

  1. Delete the VMware Cloud Foundation account from VCF Operations --> Administration -->Integrations.
  2. Delete the stale entries from fleet management appliance following VCF Instance not removed from the fleet management appliance database after deleting the integration in VCF Operations.
  3. Re-add VMware Cloud Foundation account in VCF Operations --> Administration -->Integrations.