Receiving 415 Unsupported Media Type error from a REST call to the DA REST API of CA Performance Manager (CAPM)
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Receiving 415 Unsupported Media Type error from a REST call to the DA REST API of CA Performance Manager (CAPM)

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Article ID: 4320

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Content-Type errors importing Monitoring Profiles via REST

Errors are observed using a REST client with the CA Performance Manager product. An error stating "415 error (Unsupported Media Type)" is observed from a REST client when working with CA Performance Manager.

DX NetOps Performance Management REST web services for Certification changes are returning an error. Trying to import a certification change returns an error.

Can be observed in all releases of Performance Manager

Can be observed in all REST clients available

Can be observed when targeting the CA Performance Center server or the CA Data Aggregator server with REST calls.

Can be observed using all support REST call options, including but not limited to a GET call, POST call or PUT call.

Environment

All supported DX NetOps Performance Management releases

Cause

The Content-Type value in the REST Client configuration is incorrect.

Resolution

Set the Content-Type to application/xml to resolve this. For example:

Additional Information

See the Connect a REST Client to the NetOps Portal REST Web Services Using Basic Authentication section of the Use NetOps Portal Web Services documentation topic for further information.