Content-Type errors importing Monitoring Profiles via REST

book

Article ID: 4320

calendar_today

Updated On:

Products

CA Infrastructure Management CA Infrastructure Management CA Performance Management - Usage and Administration CA Performance Management - Data Polling

Issue/Introduction

Errors are observed using a REST client with the CA Performance Manager product.

 

An error stating "415 error (Unsupported Media Type)" is observed from a REST client when working with CA Performance Manager.

Cause

Due to incorrect REST Client configuration. If the correct content type is not specified in the REST client, when it issues the call to the target REST server it fails.

Environment

Can be observed in all releases of Performance ManagerCan be observed in all REST clients availableCan be observed when targeting the CA Performance Center server or the CA Data Aggregator server with REST calls.Can be observed using all support REST call options, including but not limited to a GET call, POST call or PUT call.

Resolution

Set the Content-Type to application/xml

 

This is referenced in the Wiki Docs "Install the Client and Connect CA Performance Management". Alternatively search the existing Wiki documentation for a section titled "Install the Client and Connect CA Performance Management" and review steps 8 and 9 in that section.

 

Once set correctly the error will be resolved.

Additional Information

Please refer to the user documentation or Help section of the REST client in use.