udm_manager Not Initializing Properly in UIM 8.4
search cancel

udm_manager Not Initializing Properly in UIM 8.4

book

Article ID: 43192

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Symptoms

1. The following errors are repeated indefinitely in the log file
May 12 11:56:42:001 DEBUG [main, udm_manager] Calling Peer.createDatabase to establish Datomic connection.
May 12 11:57:12:037 DEBUG [main, udm_manager] Exception establishing Datomic connection: Error communicating with HOST 10.1.226.24 on PORT 4334
 
2. udm_manager ends with a "no-restart code (42)" after 10 minutes of the above errors occurring
May 12 12:05:42:238 [18204] Controller: Probe 'udm_manager' (command = <startup java>) returns no-restart code (42)
 
3. When observing the udm_manager process in Task Manager or top, the process may be consuming 100% CPU utilization.
4. When deactivating the udm_manager probe in Infrastructure Manager, the port may never release
 

Cause

This issue has been linked to an incorrect version of Java.  The versions necessary for UIM 8.4 are 1.7.0_80 or 1.7.0_85.
 
To verify your version, perform the following steps:
Linux
# /opt/nimsoft/jre/jre7/bin/java -version
 
Windows
Open a command prompt
Run the following command:
C:\Program Files (x86)\Nimsoft\jre\jre7\bin\java.exe -version
 
 
The output should indicate that you have 1.7.0_80 or 1.7.0_85 as below:
 
java version "1.7.0_80"
Java(TM) SE Runtime Environment (build 1.7.0_80-b15)
Java HotSpot(TM) 64-Bit Server VM (build 24.80-b11, mixed mode)


If you have any other version output, then the java_jre probe will need to be redeployed.
 

Resolution

  1. Open the Nimsoft Service Controller
  2. Stop the Nimbus service
  3. Delete the jre7 folder
  4. Start the Nimbus service.
  5. Log into Infrastructure Manager.  You will see numerous probes that failed to start.  This is expected at this stage.
  6. Access your Archive in Infrastructure Manager and drag the java_jre package to your primary hub.
  7. When the deployment has completed, stop and start the Nimbus service again.
  8. Verify udm_manager functionality.
If the issue continues -
  1. Open a command prompt
  2. Run the following command:
  3. java --version
  4. If this returns a different version of java than java version "1.7.0_80" or "1.7.0_85"
  5. Navigate to your primary hub's controller in Admin Console or Infrastructure Manager
  6. Add a new environmental key "PATH" with value " ". Do not include the quotes.
  7. Restart the primary hub.
  8. This forces the robot to use the nimsoft/jre and not the system jre.
 

Additional Information

It is normal to see the following log entries repeated three times on startup and is not cause for concern:
May 12 11:56:42:001 DEBUG [main, udm_manager] Calling Peer.createDatabase to establish Datomic connection.
May 12 11:57:12:037 DEBUG [main, udm_manager] Exception establishing Datomic connection: Error communicating with HOST 10.1.226.24 on PORT 4334

Environment

Release: CNMSPP99000-8.4-Unified Infrastructure Mgmt-Server Pack-- On Prem
Component: