ESXi ホストのログ記録が停止し、最終的に応答しなくなる
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ESXi ホストのログ記録が停止し、最終的に応答しなくなる

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Article ID: 431787

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VMware vSphere ESXi

Issue/Introduction

免責事項:これは英文の記事「ESXi host stops logging and eventually becomes unresponsive.」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • ESXi 8.0.1 以降へのアップグレードまたはアップデート後、ESXi のログ記録が停止し、最終的に応答しなくなります。
  • この事象は、ESXi 7.0.1 以降でも発生することが確認されています。
  • この問題の発生はランダムであり、どのホストがこの問題の影響を受けるかを特定する確実な方法はありません。
  • 通常、ホストはログの記録が停止してから 12 ~ 24 時間以内に応答しなくなります。
  • vmkernel.log、vobd.log、hostd.log、vmkwarning.log、vmksummary.log など、ホストのすべてのログにおいてログの出力が停止します。

 

Environment

vSphere ESXi 7.X

vSphere ESXi 8.X

Cause

vmsyslogd をリロードすると、vmsyslogd に SIGHUP シグナルが送信されます。極めて短い間隔で複数のリロードシグナルが送信された場合、シグナルハンドラが非同期シグナルセーフ関数を使用していないことが原因で、デッドロックが発生する可能性があります。

Resolution

以下のリリースで修正されています:

回避策:

  1. ホストが応答しなくなる前にこの問題を回避するには、pkill vmsyslogd を実行します。ウォッチドッグが自動的にサービスを再起動し、機能が復旧します。
    pkill vmsyslogd
  2. ホストがすでに応答しない状態に陥っている場合、唯一の復旧方法はホストを再起動することです。