Service Engine Metrics Not Visible in UI When Real-Time Metrics Are Enabled
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Service Engine Metrics Not Visible in UI When Real-Time Metrics Are Enabled

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Article ID: 431750

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Updated On:

Products

VMware Avi Load Balancer

Issue/Introduction

  • On the Controller UI, the CPU usage, memory usage, and disk usage metrics for the Service Engines (SEs) appear empty when Real-Time Metrics are enabled.

Environment

  • Avi Load Balancer
  • Affected Version: 30.x ,31.1.x

Cause

  • The issue occurs due to a bug in the Real-Time metrics collection method (Push Mode), which prevents the metrics from being displayed correctly in the UI.

Resolution

Workaround:

Perform all the following steps to fix this issue.

  1. Disable Real-Time Metrics in the SE Group (UI):

    • Navigate to the SE Group configuration.

    • Edit the SE Group and uncheck “Enable Real-Time Metrics.”

  2. Set Metrics Collection Mode to Pull Mode via CLI:

     
    configure serviceenginegroup <Name of the SE group>
    metrics_collection_mode 0
    save

    Note: The metrics_collection_mode parameter supports three values: 0 (Pull Mode) ,1 (Push Mode) and  9(Special value)

     

  3. Disable Real-Time Metrics on Virtual Services and Pools

    • Ensure that Real-Time Metrics are disabled on all Virtual Services (VS) and Pools where it may be enabled.

 

Fix:

 

  • Starting from version 31.2.1, the default metrics_collection_mode is set to 0 (Pull Mode).

  • This change is also planned to be introduced in 30.2.7.

 

Additional Information

 

  • It is best to set metrics_collection_mode to 0 (Pull Mode) before performing an upgrade.

  • It is not advisable to have too many objects with Real-Time (RT) metrics enabled.

  • If Real-Time Metrics are required, they should be re-enabled, while keeping the metrics_collection_mode set to 0 on the SE Group.