SNMP v3 discovery of device, shows only ICMP response

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Article ID: 4317

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps CA Spectrum

Issue/Introduction

Discovery of device, using an SNMP v3 profile, only responds to ICMP

Cause

The settings in the SNMP v3 profile may be incorrect

Environment

CA Performance Management, all versions

Resolution

See if you can get a walk of the device, with a 3rd party tool, using the information from the SNMP v3 profile that you had created (using sapwalk2, in this case)

example:

sapwalk -i 192.168.1.12 -v v3 -s 1.3.6.1.2.1.16 -n 2 -u xxxxxx -xt SHA -xa xxxxxx -xp xxxxxx -p 161 -l AP

#sapwalk2: ver 2.12 

#Copyright (c) 1994-2010 SIMPLESOFT Inc. 

#Address=192.168.1.12, StartOid=1.3.6.1.2.1.16 

#TimeOut=90000, MaxRetries=3, CompareFlag=0 

#args: -i 192.168.1.12 -v v3 -s 1.3.6.1.2.1.16 -n 2 -u xxxxx -xt SHA -xa xxxxx -xp xxxxx -xe AES128 -p 161 -l AP 

Error: Received unexpected Report PDU[1.3.6.1.6.3.15.1.1.5.0(usmStatsWrongDigests.0)]. walk stopped

 

The error received above indicates an incorrect auth password, or incorrect auth type (MD5/SHA).
Please check the settings and try again.

You may need to put the authentication and privacy passwords in-between single quotes ( ' ).

Example:

sapwalk2 -i XXX.XXX.XXX.XXX -v v3 -s 1 -u AuthPrivUser -l AP -xt MD5 -xa 'authpassword' -xp 'privpassword' –xe DES -o device_mib.walk

 

Additional Information

How to use sapwalk to get a mib dump file

https://knowledge.broadcom.com/external/article/48972/

How to SNMPWalk2 a v3 device

https://knowledge.broadcom.com/external/article/48796/