XOG Error - Cannot read the array length because "profiles" is null
search cancel

XOG Error - Cannot read the array length because "profiles" is null

book

Article ID: 431681

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Tried to xog out the process and got this error java.lang.NullPointerException: Cannot read the array length because "profiles" is null

  • <NikuDataBus xmlns:xsi=http://www.w3.org/2001/XMLSchema-instance xsi:noNamespaceSchemaLocation="../xsd/nikuxog_contentPack.xsd">
  • <Header action="write" externalSource="NIKU" objectType="contentPack" version="16.3.3.1555"/>
  • <XOGOutput>
  • <Object type="contentPack"/>
  • <Status state="FAILURE"/>
  • <Statistics failureRecords="0" insertedRecords="0" totalNumberOfRecords="1" updatedRecords="0"/>
  • <Records>
  • <Record>
  • <KeyInformation/>
  • <ErrorInformation>
  • <Severity/>
  • <Description/>
  • <Exception><![CDATA[
  • java.lang.NullPointerException: Cannot read the array length because "profiles" is null
  • at com.niku.bpm.services.oi.odf.ODFUtils.getProfile(ODFUtils.java:95)
  • at com.niku.bpm.services.oi.odf.BpmObjectImpl.getProfile(BpmObjectImpl.java:550)
  • at com.niku.bpm.xbl.handlers.XOGGetAssignees.getObjectProfileAssignees(XOGGetAssignees.java:157)
  • at com.niku.bpm.xbl.handlers.XOGGetAssignees.postProcess(XOGGetAssignees.java:65)
  • at com.niku.xql2.XQLVisitor.postProcess(XQLVisitor.java:1439)
  • at com.niku.union.xml.dom.DOMWalker.postProcess(DOMWalker.java:217)
  • at com.niku.union.xml.dom.DOMWalker.traverseIntern(DOMWalker.java:97)
  • at com.niku.union.xml.dom.DOMWalker.traverseIntern(DOMWalker.java:95)
  • at com.niku.union.xml.dom.DOMWalker.traverse(DOMWalker.java:54)
  • at com.niku.xql2.handlers.LoopHandler.processObject(LoopHandler.java:388)
  • at com.niku.xql2.handlers.LoopHandler.processSet(LoopHandler.java:259)
  • at com.niku.xql2.handlers.LoopHandler.preProcess(LoopHandler.java:216)

Environment

Any Supported Clarity Release

Cause

  • This is connected to Object roles (specifically Manager) not being available as a Process Action Item assignee for CIT.
  • XOG accepts invalid values on Assignees on Import and validation.
  • Then the process hangs at runtime

Resolution

Workaround

  1. Check the process assignees - In the Classic PPM UI, go to the process definition and check which steps/actions have "Object Profile" or "Template Profile" type assignees
  2. Remove problematic assignees - Temporarily remove object profile assignees, export, then re-add them manually in the target
  3. Use selective export - If exporting a content pack, try excluding the problematic process or its assignee configuration