Zerto Failover Performance Degradation on VMware Cloud Director when certain cell(s) are up and running
search cancel

Zerto Failover Performance Degradation on VMware Cloud Director when certain cell(s) are up and running

book

Article ID: 431677

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Zerto failover activities experience significant performance degradation when specific VCD cell(s) are powered on and included in the load balancer configuration. While failover testing is performant with fewer cells, adding these specific application and witness VCD cell(s) can increase the failover timeline from minutes to hours for even small virtual machines.

 

 

Environment

VMware Cloud Director, Zerto or other backup softwares.

Cause

The degradation is caused by a network configuration conflict where a VCD cell's `eth0` management IP address matches the network's broadcast address or other used IP in the network. This conflict creates network instability and slowness when the affected cell is active and as a result causes delay in failover activities. 

Resolution

To resolve this issue, you must modify the network configuration one or more VCD cells as needed to ensure no conflict exists with any assigned cell IP addresses. Follow these steps for each cell:

  1. Perform a Backup: Take a full backup of the VMware Cloud Director database.
  2. Shut Down Services:
  • Connect to the cell via SSH.
  • Stop the VCD services using the following command:

    /opt/vmware/vcloud-director/bin/cell-management-tool -u administrator cell --shutdown

  1. Reconfigure the Network:
  • Run the appliance network tool:
    /opt/vmware/share/vami/vami_config_net

  • Choose Option 6 to modify the IPv4 address for eth0.
  • Enter the correct netmask, IP that resolves the address conflict.
  1. Verify Configuration: Type ifconfig to verify the new netmask is applied to the interface.
  2. Update vCenter Settings: 

    In the vSphere Client, locate the VCD cell VM.
  • Modify the vApp options and update the value for the label eth0 Network Netmask (or whichever change is necessary)
  1. Restart the Cell: Power the cell VM off and then back on.

 

Additional Information