Unable to synchronize the LDAP groups for a specific user in vIDM
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Unable to synchronize the LDAP groups for a specific user in vIDM

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Article ID: 431633

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Updated On:

Products

VCF Operations

Issue/Introduction

  • Directory sync reports the error: 'Username is already there'.
  • Manual user deletion via the administration console fails with: 'User not found'.

Environment

VMware Identity Manager 3.3.7

Cause

The issue is caused by a Distinguished Name (DN) mismatch between Active Directory and the VMware Identity Manager database, causing a logic deadlock.

Resolution

Resolving this deadlock requires manual database manipulation to rename the stale records, which allows the synchronization engine to correctly re-import the users.

Please contact Broadcom Support to perform these steps and cite this KB article for reference.