Service Now displays incorrect drop down data type for text fields in custom forms synced from Aria Automation.
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Service Now displays incorrect drop down data type for text fields in custom forms synced from Aria Automation.

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Article ID: 431596

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • A Service now catalog item synced from Aria Automation displays the wrong data type for a field. For example drop down instead of text.
  • The form was originally imported into Aria Automation.
  • Validating the field in the Aria Automation UI shows it correctly as text type.
  • Exporting the cusotm form and reviewing yaml you see a value list entry under the affected field.

 

Environment

Aria Automation 8.x

Cause

When the yaml of a custom form is edited outside the UI and imported back then subsequent changes to the form in the UI may leave remnants of the previous configurations done outside the UI leaving inconsistent content.

This results in Service Now selecting the incorrect datatype for the fields when content is synced.

Resolution

To resolve the issue:

1. Export the affected custom form

2. remove the value list section from the relevant field in the yaml.

3. Import the corrected yaml as new custom form in Aria Automation

4. Perform service now sync


Validate it no longer shows as drop down in service now.