VMware ESXi ホストからリモートサーバーへの Syslog 送信が停止する
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VMware ESXi ホストからリモートサーバーへの Syslog 送信が停止する

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Article ID: 431545

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VMware vSphere ESXi

Issue/Introduction

免責事項:これは英文の記事「VMware ESXi host stops sending syslogs to remote server」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • ESXi ホストからリモート syslog サーバーへのログ送信が停止する
  • 次のイベントメッセージが出力されます:

esx.problem.vmsyslogd.remote.failure

  • /var/log/vobd.log ファイルに、以下のようなエントリが記録されます

[UserLevelCorrelator] nnnnnnnnus: [vob.user.vmsyslogd.remote.failure] The host "x.x.x.x:514" has become unreachable. Remote logging to this host has stopped.

:上記のログの抜粋はあくまで一例です。日付、時刻、および環境変数は、ご使用の環境によって異なる場合があります。

Environment

VMware vSphere ESXi 7.0 以降

Cause

このイベントは、ESXi の syslog サービスが、リモート syslog サーバーへのメッセージ送信を停止したことを示しています。この問題は、次のような場合に発生する可能性があります:

  • ネットワーク接続が中断された
  • リモートホストが接続を突然終了した
  • ファイアウォールが、Syslog サービスの通信に使用されるポートをブロックしている
  • リモート syslog サーバーがオフラインである

Resolution

切断の原因

  1. ESXi ホスト上のログファイル /var/log/.vmsyslogd.err を確認し、ESXi ホストの vmsyslogd サービスの観点から、接続失敗が発生した時間帯と、記録されている原因を特定します。
  2. ESXi ホストが、リモート syslog サーバーにログを送信するよう正しく構成されているか確認してください。
  3. リモート syslog サーバー側のログが、接続失敗の時間帯と一致しているか確認してください。また、リモート syslog サーバーの観点から記録されている接続失敗の原因を特定してください。
  4. ESXi ホストとリモート syslog サーバー間のネットワーク接続経路に、一時的または恒久的な中断が発生していないか確認してください。
  5. ESXi ホストからのログ送信が、自動的にリモート syslog サーバーへ再開されているか確認してください。

自動再接続

一部のバージョンの vSphere ESXi では、ネットワーク中断後、syslog サービスがリモート syslog サーバーへ自動的に再接続します。

手動再接続

vSphere ESXi の syslog サービスが、リモート syslog サーバーへの接続を自動的に再確立しない場合は、手動で再接続を行います。

手動で再接続するには:

  1. ローカルの ESXi Shell を開きます(例:ESXi へ SSH 接続します)。
  2. 次のコマンドを実行して syslog サーバーをリロードします: esxcli system syslog reload

esxcli system syslog reload コマンドで Failed to signal reload to vmsyslogd というエラーが返された場合、vmsyslogd プロセスが実行されていない可能性が高いです。その場合は、次の「サービスの起動」セクションの手順に進んでください。

サービスの起動

vSphere ESXi の syslog サービスが正常に動作していない、または終了してしまっている場合は、サービスを起動します。

syslog サービスを起動するには:

  1. 問題が発生している ESXi ホストで、ローカルの ESXi Shell を開きます。
  2. 次のコマンドを実行し、syslog サービスデーモン(vmsyslogd)が実行されていないことを確認します: ps -Cuv | grep vmsyslogd 
  3. 上記のコマンドで結果が何も返されない(表示されない)場合、次のコマンドを実行して syslog サービスデーモンを起動します: /usr/lib/vmware/vmsyslog/bin/vmsyslogd 
  4. 次のコマンドを実行して、syslog の構成をリロードします: esxcli system syslog reload