ServiceNow ITSM Plug-in registration failure in VCF Automation 9.x
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ServiceNow ITSM Plug-in registration failure in VCF Automation 9.x

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Article ID: 431512

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Updated On:

Products

VCF Automation

Issue/Introduction

  • When attempting to register the ServiceNow ITSM Plug-in for VCF Automation with VCF Automation 9.x, the process fails with an error :

    Entered details are invalid [ Please verify Host Url / Username / Password or Mid Server status (if Mid Server is required)]
  • Host URL is correctly formatted as https://vcfa_fqdn

  • No Username or Password is required for VCF Automation 9.x

  • The Refresh Key in these failing scenarios is typically generated from a service account created within VCF Automation via Infrastructure > Administration > Access Control > Service Accounts

Environment

VCF Automation 9.x

Cause

The integration of the ServiceNow ITSM Plug-in using internal Service Accounts created directly in VCF Automation (VM Apps) is unsupported.

Resolution

  1. Use a service account sourced from OIDC, LDAP, or a SAML origin for the ServiceNow ITSM integration.

  2. Assign the required roles to the integration user.

  3. Generating API Token for the Integration User on VCF Automation and use it as the refresh key for integration.