'FSDB file corruption detected' persistent alert with 0 triggered symptoms in VCF Operations
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'FSDB file corruption detected' persistent alert with 0 triggered symptoms in VCF Operations

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Article ID: 431486

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Updated On:

Products

VCF Operations

Issue/Introduction

  • You observe a persistent "FSDB file corruption detected" alert on a VCF Operations cluster node.
  • This issue may occur after database maintenance is performed to clear guest file system metrics from the database.
  • You can verify the issue by observing the active alert on the Node object in the VCF Operations UI. However, this alert shows no visible symptoms to check in the UI.
  • Reviewing the /storage/log/vcops/log/analytics-<GUID>.log on the rnode reveals the following:

    Problem alert caused by 0 triggered symptoms and 0 non-triggered symptoms alertDefinitionId=AlertDefinition-vCenter Operations Adapter-CorruptedFSDBFilesAlert
  • Further reviewing the analytics logs on the node, you see historical CorruptedFileException and DataBlock CRC Failure errors that reference specific resources that are already deleted from the system.
  • Attempting to clear the FSDB cache (/storage/db/vcops/data/cache/*.cache) or following the steps in Corrupted FSDB files due to unrealistic timestamp (340117) does not resolve the issue, and the alert immediately returns after you manually cancel it.
  • Additionally, /storage/log/vcops/log/vcops-bridge.log displays the following entry, which points to phantom symptoms:

    2026-01-28T22:06:32.069Z INFO vcfops-bridge 32363 [ops@4413 threadId="910" threadName="ServerConnection on port 10000 Thread 11"] [com.vmware.vcops.bridge.server.ProblemAlertsManager.getSymptomDetailsForAlert_aroundBody50] - The alert [GUID] does not have any triggered symptoms, but only triggered NOT symptoms

 

Environment

VCF Operations 9.x

Cause

The persistent alert is caused by orphaned "FSDB corruption" symptom entries stuck in the Postgres vcopsdb database for the related VCF Operations Fsdb-<HOSTNAME> object.

The health alert on the main VCF Operations Node object relies on symptoms from this associated FSDB object. Because the database retains these old symptoms for previously deleted resources, the alert continues to trigger as a false positive. While the symptoms remain active on the Fsdb object, there is no UI method to cancel them.

Resolution

To determine if your VCF Operations cluster is affected by this issue, you can use the UI to check for active false symptoms.

  1. In the VCF Operations UI, review the active "FSDB file corruption detected" alert on the affected VCF Operations Node.
  2. Verify that this alert shows no active symptoms directly on the Node object.
  3. Navigate to the associated VCF Operations Fsdb-<HOSTNAME> object in the UI inventory. You can use the Global Search at the top of the page.
  4. Review the active symptoms for this Fsdb object and confirm there are active false symptoms related to FSDB corruption.

If you observe an active alert on the Node with no symptoms, and active false symptoms on the associated Fsdb object, please contact Broadcom Support and reference this Knowledge Base article for assistance.

Additional Information