Cannot ping or connect to a VMkernel adapter
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Cannot ping or connect to a VMkernel adapter

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Article ID: 431443

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

After creating a new VMkernel adapter (vmk) on an ESXi host, the interface is unreachable.

Pings to the VMkernel IP address fail, and services relying on this interface (such as VM restores, NFS, or vMotion) cannot connect.

Cause

The Virtual Standard Switch (vSwitch) hosting the newly created VMkernel port group may not have an active physical network adapter (vmnic) assigned to it.
Without a physical uplink, the VMkernel adapter is isolated to the internal vSwitch and cannot route traffic to the external physical network.

Resolution

Assign an available physical uplink (vmnic) to the vSwitch using the vSphere Host Client.

  1. Log in to the ESXi Host Client (https://<ESXi_IP_Address>/ui) using root credentials.
  2. In the Navigator pane on the left, click on Networking.
  3. Select the Virtual switches tab.
  4. Click the name of the vSwitch associated with the unreachable VMkernel adapter (e.g., vSwitch1).
  5. Click Edit settings.
  6. In the Edit virtual switch dialog, locate the Uplink 1 field. (If no uplink section is present, click Add uplink).
  7. From the drop-down menu, select an available and physically connected network adapter (e.g., vmnic1).
  8. Click Save to apply the configuration.
  9. Validate connectivity by pinging the VMkernel interface IP address from a device on the same subnet.

Additional Information

If the vmnic is successfully attached but the VMkernel adapter remains unreachable, verify that the upstream physical switch port connected to the assigned vmnic is configured to allow the VLAN ID specified on the VMkernel port group (or if the physical switch port is set as an Access port for the desired VLAN, ensure the VMkernel port group has no VLAN assigned).

See also: