Job Failed With Message: Job was processing when scheduler restarted
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Job Failed With Message: Job was processing when scheduler restarted

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Article ID: 431439

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

The job starts at its scheduled time but it fails.

Check the Reports and Jobs > Jobs > Log page and filter for the job that failed.

The failure reason is:
 "Job was processing when scheduler restarted."



Environment

Any

Cause

If the background services are restarted, which serves jobs, then the job will fail.

Resolution

Perform the following:

1. Determine if the service restart is one-off, intermittent, or at a scheduled occurrence.

2. Go to Reports and Jobs > Log
Filer for the job.

Review the screenshot/runtime history.
Determine when was the last time the job completed and find out how long did it took?

Determine if the start/finish/runtime of the job and compare it against when the BG service restarts.

3. To avoid disruption, schedule the job with a completion buffer before the anticipated restart time.

This is to ensure it is allowed time to complete.