Login prompt to Clarity application is looping more than once
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Login prompt to Clarity application is looping more than once

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Article ID: 431430

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Scenario under consideration:

  • Clarity uses Azure EntraID as the Identity Provider
  • When a user uses the Clarity URL, it gets redirected to the EntraID URL
  • A login prompt is presented
  • Once the user provides the username, another login prompt is presented
  • The user has to provide the same username again to then get the password prompt
  • Upon successful verification of the password, EntraID successfully redirects to Clarity

Why is it that the username has to be filled in twice?

Cause

EntraID app is configured with both OData and SAML based authentication.

Resolution

Only SAML based authentication is required. Configure the app to use SAML only.