System Administrator が VMware Cloud Director のプロバイダーポータルからテナントポータルへアクセスする際に認証情報を求められる
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System Administrator が VMware Cloud Director のプロバイダーポータルからテナントポータルへアクセスする際に認証情報を求められる

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Article ID: 431412

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VMware Cloud Director

Issue/Introduction

免責事項:これは英文の記事「System Administrator is prompted for credentials when accessing Tenant Portal from Provider UI in VMware Cloud Director」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

VMware Cloud Director のプロバイダーポータルの UI から、System Administrator でテナント ポータルへアクセスしようとすると、テナントのログインページにリダイレクトされ、認証情報を求められる場合があります。

本来期待されるシームレスな SSO(シングルサインオン)フローに代わりこの事象が発生します。テナントの詳細に表示されるパブリック URLには、完全修飾ドメイン名 (FQDN) ではなく IP アドレスが表示されています。

Environment

VMware Cloud Director 10.3 以降

Cause

VCD の公開アドレスの設定で IP アドレスが指定されています。ロードバランサーの VIP を介した正しいセッション管理とトークン認証を行うためには、公開アドレスに SSL 証明書とロードバランサーの設定に一致する有効な FQDN が設定されている必要があります。

Resolution

この事象を解決するには、ロードバランサーの VIP の FQDN に公開アドレスを更新します。

  1. System Administrator の権限を持つユーザで VCD のプロバイダポータルへログインします。
  2. [Administration] > [設定] > [公開アドレス] を選択します。
  3. [編集] をクリックします。
  4. URL  をロードバランサーの VIP の FQDN に更新します。
  5. テナント ポータルへ再度アクセスし、セッションが正しく維持されることを確認します。