WCC Monitor Action Missing in EEM ApplicationAccess Policy
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WCC Monitor Action Missing in EEM ApplicationAccess Policy

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Article ID: 431400

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

After upgrading Workload Control Center (WCC) to version 24.x, the "Monitor" action may be missing from the ApplicationAccess policy within the CA EEM UI.
This prevents users from accessing the new Monitor tab and search bar in the Autosys Web UI. This issue typically occurs if EEM connectivity is interrupted during the policy upgrade phase of the installation.

Symptoms

  • The "Monitor" action is absent from the EEM ApplicationAccess resource class.
  • Users cannot see the Monitor tab or the Server Search bar in WCC.
  • The cawa_installer.log contains errors indicating a failed application registration:
    INFO com.ca.wla.ae.installer.mm.action.wcc.RegisterWCCEEMPolicies - Upgrading R12 EEM Policies for WCCDEBUG com.ca.wla.ae.installer.mm.action.wcc.RegisterWCCEEMPolicies - Cannot register wcc eem policies com.ca.wla.ae.installer.exception.AEEEMValidationException: [CAUAJM_E_112111] An internal error occurred while interacting with the CA EEM server.WARN com.ca.wla.ae.installer.logger.LogHelper - [CAUAJM_W_116420] Unable to register or upgrade the Web UI EEM application.

 

Environment

Autosys Workload Automation (All 24.x On-Premise versions) 

WCC (Web UI) 24.X , EEM (Embedded Entitlements Manager)

Cause

The WCC installer failed to execute the policy registration script (UWCCRegister.xml) due to an EEM connectivity error or an internal EEM server exception during the upgrade.

There was a problem during WebUI policy upgrade phase, normally this is done automatically as part of upgrade.  This could happen if there was a problem with EEM connectivity during the upgrade phase.

One example from cawa_installer.log for such a use case looks like:

2026-02-06 04:41:07,079 [main] INFO  com.ca.wla.ae.installer.mm.action.wcc.RegisterWCCEEMPolicies(67) - Upgrading R12 EEM Policies for WCC
2026-02-06 04:41:07,081 [main] INFO  com.ca.wla.ae.installer.eem.WccEEMUtils(63) - EEM is already initialized.
2026-02-06 04:41:07,092 [main] DEBUG com.ca.wla.ae.installer.mm.action.wcc.RegisterWCCEEMPolicies(77) - Cannot register wcc eem policies com.ca.wla.ae.installer.exception.AEEEMValidationException: [CAUAJM_E_112111] An internal error occurred while interacting with the CA EEM server.
2026-02-06 04:41:07,093 [main] WARN  com.ca.wla.ae.installer.logger.LogHelper(52) - NonFatalException : W_AE_WCC_EEM_RegisterApp_Failed [CAUAJM_W_116420] Unable to register or upgrade the Web UI EEM application.
[CAUAJM_W_116420] Unable to register or upgrade the Web UI EEM application.
2026-02-06 04:44:17,812 [main] DEBUG com.ca.wla.ae.installer.customaction.AEBackUpLogs(288) - Exception occured while backing up EEM logs: 

Resolution

If you cannot revert to a pre-upgrade snapshot, use the following steps to manually register the 24.x application definitions.

Note: If you do not have a backup of your original custom policies, they will be overwritten during re-registration. You can repopulate your development environment by exporting healthy policies from a Production or Sandbox environment.

  1. Backup Current Policies: Export your existing WCC EEM policies from the EEM UI (Manage Access Policies > Export) as a precaution.
  2. Deregister the Application: Use the safex utility to remove the existing application definition:
  3. Register the 24.x Application: Run safex using the UWCCRegister.xml file located in the /safex/ directory of your WCC 24.x installation.
    • Command: safex -h [hostname] -u EiamAdmin -p [password] -f /safex/UWCCRegister.xml
  4. Restore Custom Policies: Import your saved policies or copy policies from a healthy 24.x environment.
  5. Enable the Monitor Action:
    • Log into EEM as EiamAdmin for application WCC0004.
    • Navigate to Manage Access Policies > ApplicationAccess.
    • Select your policy (e.g., ApplicationAccessDefault) and check the box for the Monitor action for the required users.
  6. Verify: Log out and log back into WCC to confirm the Monitor tab and search bar are visible.

 

Additional Information

NOTE: This assumes that you have a backup of WCC EEM policies from the older release prior to performing the steps below.

  • unregister WCC0004 application in EEM UI
  • register WCC0004 using  UWCCRegister.xml from 24.1.01  (<wcc>/safex/UWCCRegister.xml)
  • load custom backup WCC policies from older release, via safex
  • now the custom policies should contain the upgraded changes that are needed for 24.x release
  • Regenerate WCC certificates in EEM if needed using the WCC section in this document.