Unable to send alert emails from vCenter using child domain email addresses following a certificate change
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Unable to send alert emails from vCenter using child domain email addresses following a certificate change

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Article ID: 431356

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • The issue is seen after changing the vCenter Server (VC) certificates.
  • The email address being used is of the format [email protected]
  • An email from the parent domain of the format [email protected] can successfully send alert emails.
  • The affected email address when used with other solutions(backup etc.) can successfully send alert emails using the same SMTP settings.
  • In the /var/log/messages file on the VC, we see the entries of the following type that can be ignored:
    <Timestamp> <VC name> sendmail[######]: 61BGQTFT######: [email protected], [email protected] (0/0), delay=00:00:28, xdelay=00:00:12, mailer=relay, pri=30956, relay=[127.0.0.1] [127.0.0.1], dsn=4.4.2, stat=Deferred: Name server: [127.0.0.1]: host name lookup failure
  • The name resolution works as expected.

Environment

VMware vCenter Server 8.x

Cause

The issue happens due to configuration issues when the SMTP server blocks the mails from VC appliance using the child domain email address.

Resolution

To resolve the issue, review the configuration on the SMTP server side to allow communication from VC using child domain address. 

Note: This is not within the scope of Broadcom support as the SMTP server is managed by your organization.

Additional Information

Unable to send emails via relay SMTP after replacing vCenter certificates