NSX 9.0.x でライセンスが vCenter と同期されない
search cancel

NSX 9.0.x でライセンスが vCenter と同期されない

book

Article ID: 431315

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

免責事項:これは英文の記事「NSX 9.0.x license not synced with vCenter」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • VCF ライセンスがより高いコア容量に拡張されました。新しいライセンス容量は VCF Operations および vCenter には反映されていますが、NSX では依然として古いライセンス情報が表示されます。
  • ライセンス変更が行われた後でも、nsxapi.log に以下のようなログが出力されることがあります。

    INFO pool-###-thread-1 VCSyncServiceImpl #### SYSTEM [nsx@####   comp="nsx-manager" level="INFO" subcomp="manager"] Update VCF license, 0 to create, 0 to delete

Note: 上記のログは一例です。日付、時間、および環境変数は、お客様の環境によって異なる場合があります。

 

Environment

VMware NSX 9.x

Cause

ライセンス同期リクエストは NSX から vCenter へ送信されていますが、コードの不具合により、NSX がライセンスの変更を検出しません。

NSX および vCenter のライセンス情報を確認する方法:

  • API を使用して NSX Manager からライセンス情報を取得する:
     GET https://{{nsx-ip}}/api/v1/licenses

  • vCenter Server からライセンス情報を取得する:
    GET https://{{vCenterHost}}:443/api/cis/license/subscription/entitlement/vcenter-assignments

Resolution

これは VMware NSX が影響を受ける既知の問題です。

Workaround

vCenter と NSX の間の接続を一時的に切断することで、ライセンスの再同期を強制的に実行します。

注意事項: この回避策を実行する際は、アップグレード中やトラフィック負荷の高い時間帯ではないことを確認してください。操作中に NSX の構成変更を行わないでください。

NSX 9.0 では、vCenter が NSX から削除または切断されると、ライセンス同期の失敗により、NSX は vCenter から既存の VCF ライセンスを削除します。そのため、vCenter と NSX の接続を切断してライセンス同期をトリガーさせることが可能です。既存の古い VCF ライセンスが削除された後、接続を復元して再度ライセンス同期を行います。

以下の手順では、NSX Manager ノードを 1 つ選択し、そのノードの IP アドレス(VIP ではない)を使用してください。

  1. SSH で NSX Manager ノードにログインし、NSX Manager から vCenter へのトラフィックをブロックするための iptables ルールを追加します。
    root@nsxmanager:/tool# iptables -t raw -A OUTPUT -d {vcIP} -j DROP

     

  2. ブラウザから該当する NSX Manager ノードの IP にログインし、"REFRESH"をクリックしてライセンス同期をトリガーします。このステップには約 5 分かかります。
  3. "REFRESH" が完了後にライセンスページをリロードし、既存の VCF ライセンスが削除されていることを確認します。
  4. SSH で該当の NSX Manager ノードにログインし、既存の VCF ライセンスが削除されている場合は、iptables ルールを削除して接続を復元します。
    root@nsxmanager:/tool# iptables -t raw -D OUTPUT -d {vcIP} -j DROP
  5. ブラウザから該当する NSX Manager ノードの IP にログインし、"REFRESH" リンクボタンをクリックしてライセンス同期をトリガーします。
  6. 「更新」操作が完了したら、ライセンスページをリロードし、新しい VCF ライセンスが取得されていることを確認します。

上記の回避策で解決しない場合は、Broadcom サポートでサポートケースを作成し、この KB 記事番号を伝えてください。

Creating and managing Broadcom cases