Users disabled and IP's blocked when accessing DA
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Users disabled and IP's blocked when accessing DA

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Article ID: 431137

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

Data Aggregator (DA) synchronization fails and users are unable to log in to the DA․․․․

 

The following AuthenticationLog.log

ERROR MESSAGE: "WARN | AuthenticationLog | User 1 in ssoToken is disabled"

Environment

Dx NetOps Performance management 23.3 +

Cause

Rogue script with bad credentials

Resolution

 

Check the following

  • IDENTIFY BLOCKED USERS AND IP ADDRESSES: Access the following debug URLs to determine which users or IPs are restricted from hitting the DA:

    PC: http://[ServerName]:8181/pc/center/admin/debug/spring/bean/loginFailureTracker DA: http://[ServerName]:8581/debug/dispatcher/container/com.ca.im.data-manager.core.authentication/bean/AuthenticationService SSO: http://[ServerName]:8381/sso/webservices/admin/debug/spring/bean/loginFailureTracker

    EXPECTED: List of blocked entities is displayed.

  • LOCATE AND TERMINATE UNAUTHORIZED SCRIPTS: Audit environment for automated scripts using incorrect or expired credentials.

    EXPECTED: Discovery of rogue scripts causing repeated login failures.

In this case a rogue script with bad credentials was causing the issues.  Once the script was disabled the issue with blocked users and IP's went away

 

Additional Information

Configure DA authentication settings:

DA Authentication Settings